XMLRPC

XMLRPC::LiteをインストールしようとするとXML::Parserで怒られ、XML::ParserをインストールしようとするとNet::SSLeayのバージョンが低すぎると怒られる
なんやかよく分からないので、ひと通り入れなおしてみる

Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by package perl-A
perl(Net::SSLeay) >= 1.33 is needed
<<

Net::SSLeayを普通にyumでアップデートしても1.3がインストールされ1.33が入らなかったので手動で頑張る。ほんとにこれでよかったのだろうか。謎
$ cd /usr/local/src
$ yum remove perl-Net-SSLeay
$ wget http://packages.sw.be/perl-Net-SSLeay/perl-Net-SSLeay-1.36-1.el5.rfx.i386.rpm
$ rpm -i perl-Net-SSLeay-1.36-1.el5.rfx.i386.rpm

とりあえず成功したので、続いてXML::Parserを入れようとするとexpatがどうのこうのと怒られたので、インストール
$ yum isntall expat-devel

ようやく準備ができたようなので、必要なPerlのモジュールを突っ込んでみる
$ perl -MCPAN -e shell

% install XML::Parser
% install XMLRPC::Lite
<<